phpCOIN

  Reply to this topicStart new topicStart Poll

> Email Appears To Be Invalid Error
franksidebottom
Posted: October 29, 2014 07:29 am
Quote Post


Newbie
*

Group: Members
Posts: 5
Member No.: 4,623
Joined: October 28, 2014



Hi, I am just running through a test order to check functionality of the system and when setting up a new customer account I receive the following error message, no matter what email address I use.

- Some required fields may be blank.

Email appears to be invalid.


I have tried using several personal and work email addresses to no avail.

Any ideas where the problem lies?
PMEmail Poster
Top
lightman
Posted: October 29, 2014 10:19 am
Quote Post


The Janitor
***

Group: Admin
Posts: 3,639
Member No.: 3
Joined: August 25, 2006



Can you reproduce this on the http://cpdemo.phpcoin.com/ site

This site contains all the security hot-fix patches, and should perform like yours unless something in your installation, or PHP version and/or settings, is upsetting it smile.gif

(Note: The emails will not actually be sent but any error messages should still appear)


--------------------
***** Unless otherwise stated, all replies refer to the following *****
====================================================================
--- The latest unmodified version of phpCOIN available from the phpCOIN download page on the date and time of this post.
--- All relevant HotFix files applied - One of the four included unmodified themes - The original language files .
--- Help will be given to install/configure/use phpCOIN, but not programming help to modify phpCOIN operations. If you are competent enough to make programming changes, you should be competent enough to read the source code and figure things out :)
PM
Top
franksidebottom
Posted: October 29, 2014 11:21 am
Quote Post


Newbie
*

Group: Members
Posts: 5
Member No.: 4,623
Joined: October 28, 2014



Hi, I tried this on the demo and things worked out fine.

I did have to use the modified package when installing phpcoin, as the offical package would not install correctly (blank page). The same thing happened installing from Softaculous and changing php version to 5.2 did not help.

I have installed a couple of the hot fixes so far but not all (not the mail archive fix or google fix).

Any ideas what file/text I need to check for this issue?
PMEmail Poster
Top
lightman
Posted: October 29, 2014 02:02 pm
Quote Post


The Janitor
***

Group: Admin
Posts: 3,639
Member No.: 3
Joined: August 25, 2006



I only have one suggestion

In Admin > parameters > group=operation subgroup=email

Email: Use Safe Address Format
YES: Emails will be sent as only <name@address> which every mail-server will accept
NO: Emails sent from phpCOIN use the "Name <name@address>" format. Some mail-servers have a problem with this

Default is No - try the Yes option (or vice versa if you have already switched it! )


--------------------
***** Unless otherwise stated, all replies refer to the following *****
====================================================================
--- The latest unmodified version of phpCOIN available from the phpCOIN download page on the date and time of this post.
--- All relevant HotFix files applied - One of the four included unmodified themes - The original language files .
--- Help will be given to install/configure/use phpCOIN, but not programming help to modify phpCOIN operations. If you are competent enough to make programming changes, you should be competent enough to read the source code and figure things out :)
PM
Top
franksidebottom
Posted: October 30, 2014 06:15 am
Quote Post


Newbie
*

Group: Members
Posts: 5
Member No.: 4,623
Joined: October 28, 2014



Hi, thanks for the response, that didn't work out however I have managed to get this working fine.

I went back to the drawing board and removed the own3mail installation, changed the php version from 5.4 to 5.3 on my hosting account and installed 1.5.6 from Softaculous, then made the couple of line changes here

http://forums.phpcoin.com/index.php?showtopic=3316

At this stage, the site did actually load up in IE fine using the official package for the first time, however I simply could not log into admin no matter what. Tried this a few times to no avail.

I did however feel that I was on to something here, so I went about things in a similar manner only uploading the official 1.5.6 package manually once I had added each of the hot fixes.

I can now place test orders fine using the said email addresses smile.gif
PMEmail Poster
Top
lightman
Posted: October 30, 2014 08:41 am
Quote Post


The Janitor
***

Group: Admin
Posts: 3,639
Member No.: 3
Joined: August 25, 2006



Glad you got it working (I hope you installed the 1.6.5 version, and that your 1.5.6 was a typo unsure.gif )


--------------------
***** Unless otherwise stated, all replies refer to the following *****
====================================================================
--- The latest unmodified version of phpCOIN available from the phpCOIN download page on the date and time of this post.
--- All relevant HotFix files applied - One of the four included unmodified themes - The original language files .
--- Help will be given to install/configure/use phpCOIN, but not programming help to modify phpCOIN operations. If you are competent enough to make programming changes, you should be competent enough to read the source code and figure things out :)
PM
Top
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

Topic Options Reply to this topicStart new topicStart Poll

 


Inscrita el Registro Mercantil de Mallorca Tomo 2140, Hoja No. PM-51034, Folio 135
This website owned and operated by: Technology Services RPVW S.L. CIF# B57345084
Avda Constitucion 48 Bajos Alaro 07340 Baleares SPAIN
Tel:+34 971518362    Fax: +34 971518368    eMail: support@phpcoin.com